using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=from )(.+?)(?=,| to)";
string input = @"Letter from author to recipient regarding topic 11-10-2018
Letter from author, regarding topic 10-11-2018";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}