$re = '/(?<=from )(.+?)(?=,| to)/m';
$str = 'Letter from author to recipient regarding topic 11-10-2018
Letter from author, regarding topic 10-11-2018';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);