const regex = /<[^>]+>/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<[^>]+>', 'gm')
const str = `'Some text ' +
'<input type="hidden" id="hiddenField" value="3" /> ' +
'<input type="text" id="textField"/>'`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);