import Foundation
let pattern = #".*<(\d+(?:\.\d+)?).*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
7.20-<7.35
25-<32
60-<83e
40-<50
0.85-<1.15
80-<98
3.0-<3.4
NA
3.0-<3.4 (110)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)