re = /^.*\/([^\/]+)/m
str = 'hxxp://static.zipcloud.com/a/zipcloud//img/footer.break.png'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end