using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(%)(?=([0-9a-fA-F][^0-9a-fA-F]|[^0-9a-fA-F]))";
string input = @"%d%2524e%25f%255E00%%%252611%25";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}