package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z][a-z ,.'-]+(?: [A-Z][a-z ,.'-]+)*$`)
var str = `Jane Doe
Foo Bar
bar bar`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}