package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)valor(?:\s+del)?\s+fondo(?:\s+de\s+inversi[óo]n)?\D*(\d(?:[.,\d]*\d)?)`)
var str = `Valor del Fondo (Mill COP)
1,308,906.95
Valor fondo de
inversión (Mill COP)
230,942.51 Inversión inicial mínima (COP)\`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}