\+the literal + (4310 / 538 / 2B16)
the literal (3210 / 408 / 2016)
-the literal - (4510 / 558 / 2D16)
2the literal 2 (5010 / 628 / 3216)
\1the text saved by group 1
\d{3}a digit, repeated exactly 3 times
\1the text saved by group 1
\d{4}a digit, repeated exactly 4 times
\ban ASCII word boundary
g modifier: global. Finds all matches instead of stopping after the first
m modifier: multiline. Causes ^ and $ to match the start and end of each line, not only the start and end of the string