$re = '/^(?!.*(?:\h+\d+){2})[689](?:\h*\d){7}$/m';
$str = '61234567
6123 4567
6123 4567
6123 456 7';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);