#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\+?\(?([0-9]{2,4})[)\s.-]+([0-9]{3,4})([\s.-]+([0-9]{3,4}))?$"
Local $sString = "(94) 123 345" & @CRLF & _
"(94).456.7899" & @CRLF & _
"(94)-456-7899" & @CRLF & _
"94-456-7899" & @CRLF & _
"+94 456 7899" & @CRLF & _
"94 456 7899" & @CRLF & _
"0094 456 7899" & @CRLF & _
"(94) 123" & @CRLF & _
"122 3454"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")