use strict;
my $str = 'image1
image2
image3
image4
image5
image6
image7
image8
image9
image10
image11
image12
image13
image14
image15
image100
image101
image102
image103
image104
image105';
my $regex = qr/image(\d)$/mp;
my $subst = 'image00$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";