$re = '/^(1[0-3]|[1-9Qq])$/m';
$str = '12
1
9
11
22
15
q
AB';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);