#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d+).*[\r\n]+(?:\1.*[\r\n]+)*"
Local $sString = "ID,text,value" & @CRLF & _
"1,some text,5" & @CRLF & _
"1,other text,3" & @CRLF & _
"1,something,2" & @CRLF & _
"2,sample,4" & @CRLF & _
"3,john doe,2" & @CRLF & _
"3,jane doe,3" & @CRLF & _
"4,foo,1" & @CRLF & _
"4,bar,2" & @CRLF & _
"4,baz,3" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")