re = /^[A-Z0-9ČŠŽĐ](?:[A-Z0-9 ČŠŽĐ]{0,40}[A-Z0-9ČŠŽĐ])?$/i
str = 'The purpose of the given payment'
# Print the match result
str.match(re) do |match|
puts match.to_s
end