re = /(?:^|,)(?=[^"]|(")?)"?((?(1)(?:[^"]|"")*|[^,"]*))"?(?=,|$)/mx
str = ',2.99,AMO024,Title,"Description, more info",,123987564
123,2.99,AMO024,Title,"Description, more info",,123987564
"""test"" test","test""fdas""fdad",
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end