import Foundation
let pattern = #"(?<=0x\S*)S"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"0xS4321S3S testS"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)