$re = '/^(.*?)(?:-(\d{4}))?$/m';
$str = 'car-audi-tt-2
car-audi-tt-2-2019';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);