$re = '/^([a-f\d]{32}|[A-F\d]{32})$/';
$str = 'md5格式(32位)
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);