package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(.|\s)*duplicates value on record with id(.|\s)*`)
var str = `com.fasterxml.jackson.databind.exc.MismatchedInputException: Cannot deserialize instance of \`java.util.LinkedHashMap<java.lang.Object,java.lang.Object>\` out of START_ARRAY token
at [Source: (String)"[{"message":"duplicate value found: EXT_ID_EFORCE__c duplicates value on record with id: 0030Y00000XPaP8","errorCode":"DUPLICATE_VALUE","fields":[]}]"; line: 1, column: 1]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}