$re = '/<src>(?!\.\/assets\/)/';
$str = '<src>../../......</src> -- match
<src>./assets/</src> -- no match
<src>bla/bla/bla</src> -- match';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);