re = /(?<sup_all>
(?:
(?<!\\)\^
(?<sup_text>
(?>\\[\^[:blank:]\h]|[^\^[:blank:]\h\v])*+
)
(?<!\\)\^
)
|
(?: # or the Microsoft way. Beurk
\<sup\>
(?<sup_text>
((?!\v).)+
)
\<\/sup\>
)
)/x
str = '2^10^ is 1024.
Space is not allowed:
P^a cat^
But it\'s ok if it is escaped
P^a\\ cat^
Line break is a no-no, even escaped
P^a\\
cat^
Hmm <sup>This is a Microsoft superscript!</sup>
H^2^0
text^a\\ superscript^
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end