import Foundation
// WARNING: You included a flag that Swift doesn't support: J
// Wehn this flag is set, it allows duplicated capturing group names.
// By default, Swift captures only the last value matched for a repeated capture group.
// As an alternative, the pattern can be modified to contain one capturing group per group you want to get in the result.
let pattern = ##"""
(?<sup_all>
(?:
(?<!\\)\^
(?<sup_text>
(?>\\[\^[:blank:]\h]|[^\^[:blank:]\h\v])*+
)
(?<!\\)\^
)
|
(?: # or the Microsoft way. Beurk
\<sup\>
(?<sup_text>
((?!\v).)+
)
\<\/sup\>
)
)
"""##
let regex = try! NSRegularExpression(pattern: pattern, options: .allowCommentsAndWhitespace)
let testString = #"""
2^10^ is 1024.
Space is not allowed:
P^a cat^
But it's ok if it is escaped
P^a\ cat^
Line break is a no-no, even escaped
P^a\
cat^
Hmm <sup>This is a Microsoft superscript!</sup>
H^2^0
text^a\ superscript^
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)