#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(^namespace{1}.*\W\n?{)"
Local $sString = "namespace HP.Core.Extensions.ExtensionMethods" & @CRLF & _
"{" & @CRLF & _
" public static partial class FileInfoExtension" & @CRLF & _
" {" & @CRLF & _
" public static System.String GetDirectoryName(this FileInfo @this)" & @CRLF & _
" {" & @CRLF & _
" return @this.Directory.Name;" & @CRLF & _
" }" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)