using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^namespace{1}.*\W\n?{)";
string substitution = @"";
string input = @"namespace HP.Core.Extensions.ExtensionMethods
{
public static partial class FileInfoExtension
{
public static System.String GetDirectoryName(this FileInfo @this)
{
return @this.Directory.Name;
}
}
}
";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}