package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(^namespace{1}.*\W\n?{)`)
var str = `namespace HP.Core.Extensions.ExtensionMethods
{
public static partial class FileInfoExtension
{
public static System.String GetDirectoryName(this FileInfo @this)
{
return @this.Directory.Name;
}
}
}
`
var substitution = ""
fmt.Println(re.ReplaceAllString(str, substitution))
}