$re = '/(^namespace{1}.*\W\n?{)/m';
$str = 'namespace HP.Core.Extensions.ExtensionMethods
{
public static partial class FileInfoExtension
{
public static System.String GetDirectoryName(this FileInfo @this)
{
return @this.Directory.Name;
}
}
}
';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;