using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.*)?_G_(.*)_TC_(.*)_TOTAL_Sum_(.*)";
string substitution = @"TC_\3_\2_\4";
string input = @"RUBRO_G_indumentaria_TC_MONTO_TOTAL_Sum_3";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}