$re = '/(.*)?_G_(.*)_TC_(.*)_TOTAL_Sum_(.*)/';
$str = 'RUBRO_G_indumentaria_TC_MONTO_TOTAL_Sum_3';
$subst = "TC_\3_\2_\4";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;