import Foundation
let pattern = #"(.*)?_G_(.*)_TC_(.*)_TOTAL_Sum_(.*)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"RUBRO_G_indumentaria_TC_MONTO_TOTAL_Sum_3"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"TC_\3_\2_\4"#
let lookupRange = (testString as NSString).range(of: pattern, options: .regularExpression, range: stringRange)
if lookupRange.intersection(stringRange) != nil {
let result = regex.stringByReplacingMatches(in: testString, range: lookupRange, withTemplate: substitutionString)
print(result)
} else {
print("No matches were found.")
}