#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?<!\s)(?<!since)(\s*)1\.0\.0"
Local $sString = "/**" & @CRLF & _
" * @since 1.0.0 <--- this shouldn't be matched" & @CRLF & _
" * @package blah blah blah" & @CRLF & _
" * Version: 1.0.0 <--- this should be matched" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"/**" & @CRLF & _
" * Fired during plugin activation." & @CRLF & _
" *" & @CRLF & _
" * This class defines all code necessary to run during the plugin's activation." & @CRLF & _
" *" & @CRLF & _
" * @since 1.0.0 <--- this shouldn't be matched" & @CRLF & _
" * @package blah blah" & @CRLF & _
" * @subpackage blah blah" & @CRLF & _
" * @author blah blah" & @CRLF & _
" */" & @CRLF & _
"" & @CRLF & _
"define( 'PLUGIN_VERSION', '1.0.0' ); // <--- this should be matched" & @CRLF & _
""
Local $sSubst = "${1}1.2.3"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)