use strict;
my $str = '/**
* @since 1.0.0 <--- this shouldn\'t be matched
* @package blah blah blah
* Version: 1.0.0 <--- this should be matched
*/
/**
* Fired during plugin activation.
*
* This class defines all code necessary to run during the plugin\'s activation.
*
* @since 1.0.0 <--- this shouldn\'t be matched
* @package blah blah
* @subpackage blah blah
* @author blah blah
*/
define( \'PLUGIN_VERSION\', \'1.0.0\' ); // <--- this should be matched
';
my $regex = qr/(?<!\s)(?<!since)(\s*)1\.0\.0/mp;
my $subst = '${1}1.2.3';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";