#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(\d{1,3})\s*([FM])\s*\.?(\w+)\s*\.?(\w+)\s*\.?(\w+\.\w+|\w+)\s*$"
Local $sString = "95F Front Anger BW" & @CRLF & _
"95F Front Anger BW" & @CRLF & _
"95F Front Anger.BW" & @CRLF & _
"95F.Front.Anger.C.Micro" & @CRLF & _
"95F.Front.Fear.C.Micro" & @CRLF & _
"95F.Front.Frown.BW"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")