import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "([A-Z0-9]*_ECOLI)\\n([A-Z\\n]*)";
final String string = ">YBGC_ECOLI\n"
+ "MNTTLFRWPVRVYYEDTDAGGVVYHASYVAFYERARTEMLRHHHFSQQALMAERVAFVVRKMTVEYYAPA\n"
+ "RLDDMLEIQTEITSMRGTSLVFTQRIVNAENTLLNEAEVLVVCVDPLKMKPRALPKSIVAEFKQ\n"
+ ">USHA_ECOLI\n"
+ "MKLLQRGVALALLTTFTLASETALAYEQDKTYKITVLHTNDHHGHFWRNEYGEYGLAAQKTLVDGIRKEV\n"
+ "AAEGGSVLLLSGGDINTGVPESDLQDAEPDFRGMNLVGYDAMAIGNHEFDNPLTVLRQQEKWAKFPLLSA\n"
+ "NIYQKSTGERLFKPWALFKRQDLKIAVIGLTTDDTAKIGNPEYFTDIEFRKPADEAKLVIQELQQTEKPD\n"
+ "IIIAATHMGHYDNGEHGSNAPGDVEMARALPAGSLAMIVGGHSQDPVCMAAENKKQVDYVPGTPCKPDQQ\n"
+ "NGIWIVQAHEWGKYVGRADFEFRNGEMKMVNYQLIPVNLKKKVTWEDGKSERVLYTPEIAENQQMISLLS\n"
+ "PFQNKGKAQLEVKIGETNGRLEGDRDKVRFVQTNMGRLILAAQMDRTGADFAVMSGGGIRDSIEAGDISY\n"
+ "KNVLKVQPFGNVVVYADMTGKEVIDYLTAVAQMKPDSGAYPQFANVSFVAKDGKLNDLKIKGEPVDPAKT\n"
+ "YRMATLNFNATGGDGYPRLDNKPGYVNTGFIDAEVLKAYIQKSSPLDVSVYEPKGEVSWQ\n"
+ ">CN16_ECOLI\n"
+ "MIKFSATLLATLIAASVNAATVDLRIMETTDLHSNMMDFDYYKDTATEKFGLVRTASLINDARNEVKNSV\n"
+ "LVDNGDLIQGSPLADYMSAKGLKAGDIHPVYKALNTLDYTVGTLGNHEFNYGLDYLKNALAGAKFPYVNA\n"
+ "NVIDARTKQPMFTPYLIKDTEVVDKDGKKQTLKIGYIGVVPPQIMGWDKANLSGKVTVNDITETVRKYVP\n"
+ "EMREKGADVVVVLAHSGLSADPYKVMAENSVYYLSEIPGVNAIMFGHAHAVFPGKDFADIEGADIAKGTL\n"
+ "NGVPAVMPGMWGDHLGVVDLQLSNDSGKWQVTQAKAEARPIYDIANKKSLAAEDSKLVETLKADHDATRQ\n"
+ "FVSKPIGKSADNMYSYLALVQDDPTVQVVNNAQKAYVEHYIQGDPDLAKLPVLSAAAPFKVGGRKNDPAS\n"
+ "YVEVEKGQLTFRNAADLYLYPNTLIVVKASGKEVKEWLECSAGQFNQIDPNSTKPQSLINWDGFRTYNFD\n"
+ "VIDGVNYQIDVTQPARYDGECQMINANAERIKNLTFNGKPIDPNAMFLVATNNYRAYGGKFAGTGDSHIA\n"
+ "FASPDENRSVLAAWIADESKRAGEIHPAADNNWRLAPIAGDKKLDIRFETSPSDKAAAFIKEKGQYPMNK\n"
+ "VATDDIGFAIYQVDLSK\n"
+ ">6PGD_ECOLI\n"
+ "MSKQQIGVVGMAVMGRNLALNIESRGYTVSIFNRSREKTEEVIAENPGKKLVPYYTVKEFVESLETPRRI\n"
+ "LLMVKAGAGTDAAIDSLKPYLDKGDIIIDGGNTFFQDTIRRNRELSAEGFNFIGTGVSGGEEGALKGPSI\n"
+ "MPGGQKEAYELVAPILTKIAAVAEDGEPCVTYIGADGAGHYVKMVHNGIEYGDMQLIAEAYSLLKGGLNL\n"
+ "TNEELAQTFTEWNNGELSSYLIDITKDIFTKKDEDGNYLVDVILDEAANKGTGKWTSQSALDLGEPLSLI\n"
+ "TESVFARYISSLKDQRVAASKVLSGPQAQPAGDKAEFIEKVRRALYLGKIVSYAQGFSQLRAASEEYNWD\n"
+ "LNYGEIAKIFRAGCIIRAQFLQKITDAYAENPQIANLLLAPYFKQIADDYQQALRDVVAYAVQNGIPVPT\n"
+ "FSAAVAYYDSYRAAVLPANLIQAQRDYFGAHTYKRIDKEGVFHTEWLD\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}