using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"adm-list-table-cell.*<span class=\""del\"".*\<\/td";
string input = @"<td class=""adm-list-table-cell align-right""><a href=""iblock_element_edit.php?IBLOCK_ID=1&type=news&ID=2&lang=ru&find_section_section=-1&WF=Y"" title=""title"">2</a></td><td class=""adm-list-table-cell align-left adm-list-table-cell-last""> / / / / <span class=""del"">ALL</span> / / / / / / / / / / </td>";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}