re = /^(?:dog(?:, |$))+(?:cat)?$/m
str = 'dog, cat
dog, dog, cat
dog, dog, dog
dog, dog, dog, cat
dog, dog, dog, dog, cat
dog, dog, dog, dog, dog
dog, dog, dog, dog, dog, cat
dog, dog, dog, dog, dog, dog, dog, cat
dog, dog, dog, dog, dog, dog, dog, dog, dog
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end