use strict;
my $str = 'http://www.google.com.br
https://www.yahoo.edu
http://mec.gov.br
ufmt.br
www.abc_xyz.com
abc123456789.com ';
my $regex = qr/(https?:\/\/)?(www\.)?(\w{3})(\.(com|edu|gov))?(\.br)?/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}