$re = '/^In the morning.+In the afternoon.+$/m';
$str = 'In the morning I read the news, then I start my work. In the afternoon I have my lunch.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);