using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(<(?P<end>\/*)(A)(?P<number>\d+)>)(.*?)</\3\4>";
string substitution = @"<test number=""\g<number>"">\5</test>";
string input = @"<T1>
<A1>
lorem ipsum
</A1>
</T1>";
RegexOptions options = RegexOptions.Singleline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution, 1);
}
}