$re = '/#[\w\d][\w\-]*/m';
$str = '#hashtag some text #hash; #123
#has_htag
#another-hashtag
#this-is-hashtag';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);