package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*"(?:GET|HEAD|OPTIONS|TRACE|CONNECT|PATCH)\s+[^"]*"\s+(?:-)?(\d+)?\s+(\d+).*`)
var str = `28.4.27.6 - - [24/Jul/2016:22:39:57 -0700] "GET /em/faces/consoleStatus.jsp HTTP/1.1" 302 53301 [ecid: 1.0000Kmv_oiW1NeP5If_Aif1LBVVM00000L;kXhgv0ZGZKSULGSPXKTPJHSRo4USpLO] [User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 6.3) OracleEMAgentURLTiming/3.0]`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}