#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^=(\(?([a-zA-Z]{1,10}[0-9]{1,10})\)?(\+|-|\*|/)?)+$"
Local $sString = "=A1+B2*(a3+R4-v2)+a1+r5"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")