use strict;
my $str = '=A1+B2*(a3+R4-v2)+a1+r5';
my $regex = qr/^=(\(?([a-zA-Z]{1,10}[0-9]{1,10})\)?(\+|-|\*|/)?)+$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}