$re = '/([0-9]{4})\-([0-9]{2})\-([0-9]{2})/i';
$str = '2016-02-12';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);