use strict;
my $str = 'Label Owner Date
---------------------------------------------------- -------------- ----------
ICSExternalGateway-04_MJR-ICSExternalGateway-build.0 Marchen, Keith 2/25/2015
ICSExternalGateway-04_MJR-ICSExternalGateway-build.1 Marchen, Keith 2/25/2015
ICSExternalGateway-04_MJR-ICSExternalGateway-build.2 Marchen, Keith 2/25/2015';
my $regex = qr/(build.\d).*$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}