$re = '~\[(block-([0-9]+))\](.+?)\[\/\1\]~m';
$str = '[block-2] "Donec volutpat nibh sit amet libero ornare non laoreet arcu luctus. Donec id arcu quis mauris". [/block-2]';
$subst = "<blockquote class=\"tm-style\2\"><span>\n\3\n</span></blockquote>";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;