import Foundation
let pattern = #"\[(block-([0-9]+))\](.+?)\[\/\1\]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"[block-2] "Donec volutpat nibh sit amet libero ornare non laoreet arcu luctus. Donec id arcu quis mauris". [/block-2]"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"<blockquote class="tm-style\2"><span>\n\3\n</span></blockquote>"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)