import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^name\\d+\\s+0x[0-9a-f]+\\s+0x[0-9a-f]+\\s+1\\s+[1-9]\\d*$";
final String string = "name0 0x3f700000 0x160000 1 0\n"
+ "name1 0x3f700000 0x760000 1 23";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}