re = /^name\d+\s+0x[0-9a-f]+\s+0x[0-9a-f]+\s+1\s+[1-9]\d*$/m
str = 'name0 0x3f700000 0x160000 1 0
name1 0x3f700000 0x760000 1 23'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end