using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".\/download\/file.php\?id=[0-9]{6}\&mode=view";
string input = @"<a href=""./download/file.php?id=123456&mode=view""><img src=""./download/file.php?id=123456&t=1""></a>";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}